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1: Data Analysis Using SQL and Excel [Book]
Description A practical guide to data mining using SQL and Excel. Data Analysis Using SQL and Excel, 2nd Edition
shows you how to leverage the two most popular tools for data query and analysisâ€”SQL and Excelâ€”to perform
sophisticated data analysis without the need for complex and expensive data mining tools.

Bar chart report that shows sales amounts across different product categories. PivotChart report Bar chart
report that shows sales amounts across different sales territories. PivotTable report Table that shows order
quantities and sales amounts across the Internet and Reseller channels. PivotTable report Table that shows
order quantities and sales amounts across different product categories. We begin by creating the ProductSales
report. The Create PivotChart dialog box appears. In the Choose the data that you want to analyze section,
choose the Use an external data source option, and then choose the Choose Connection button. The Existing
Connections dialog box appears. Chart1 opens for editing. In the PivotChart Fields list, specify the following
options: In the Sales Summary section, choose Sales Amount. Sales Amount is displayed in the Values
section, and the report updates to display a single bar. In the Product section, choose Product Categories.
Product Categories is displayed in the Axis section, and the report updates to display sales amounts across
different product categories. To sort the bars in descending order, take the following steps: In the PivotChart
Fields list, click or touch the Product Categories dimension, and then choose the down arrow that appears. The
Select field dialog box appears. To do this, drag the report so that the upper-left corner aligns with the
upper-left corner of cell B10 in the worksheet. Tip Ensure that the name that you specify contains only
alphanumeric characters no spaces. To do this, follow these steps: In an empty section of the report, such as
inside the upper-right corner of the report, right-click or touch and hold for a second , and then choose Format
Chart Area. The Format Chart Area list opens. Below the Chart Options, choose the Size and Properties
toolbar command. Expand the Size section, and then choose the Lock aspect ratio option. To optionally
specify alternate text for the report, expand the Alt Text section, and then type the text that you want to use for
the report. Close the Format Chart Area list. Save the workbook by using a file name such as Adventure
Works Sales. Keep the workbook open. At this point, we have created a PivotChart report. The next step is to
create another PivotChart report and name it GeoSales that shows sales amounts across different geographical
locations. On the Insert tab, choose PivotChart. Chart2 opens for editing. Move the chart so that its upper-left
corner aligns with the upper-left corner of cell J10 in the worksheet. The report updates to display a bar chart
showing sales amounts for Europe, North America, and Pacific. Specify size settings for the report by
following these steps: In an empty section of the report, right-click or touch and hold for a second , and then
choose the Format Chart Area option. To optionally specify alt text for the report, expand the Alt Text section,
and then type the text that you want to use for the report. Specify a new name for the report. On the File tab,
choose the Save button. At this point, we have created two reports. The next step is to create the ChannelSales
report. To create the ChannelSales report In Excel, on the same worksheet that was used to create the previous
reports, choose cell B On the Insert tab, choose PivotTable. Choose the Existing Worksheet option, and then
choose the OK button. PivotTable3 opens for editing. In the PivotTable Fields list, specify the following
options: In the Sales Channel section, choose Sales Channel. The report updates to display a table showing
order counts and sales amounts for the Internet and Reseller channels. Then press the Enter key. Keep the
Excel workbook open. At this point, we have created three reports using the same data source. The next step is
to create the OrderSales report. To create the OrderSales report In Excel, on the same worksheet that was used
to create the previous reports, choose cell H PivotTable4 opens for editing. The report updates to display a
table showing order counts and sales amounts for different product categories. Choose cell H26, and then, in
the Formula bar, delete the default text that says Row Labels, and then type Products. At this point, we have
created our four reports for our basic dashboard. The next step is to create a filter. Create a filter Using Excel,
there are several different kinds of filters we can create. For example, we can create a simple filter by putting a
field in the Filter section of the Fields list. We can create a slicer, or, if we are using a multidimensional data
source such as Analysis Services, we can create a timeline control. This filter will enable people to view
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information for a particular time. To create a timeline control In Excel, on the same worksheet that was used to
create the reports, choose cell B1. On the Insert tab, in the Filter group, choose Timeline. The Insert Timelines
dialog box appears. Choose the Date option, and then choose the OK button. A timeline control opens. Move
the timeline control so that its upper-left corner aligns with the upper-left corner of cell B1. To make the
timeline control wider, use the resizing handles, and drag the sizing handle on the right side of the control to
column M. Select the timeline control, and then, on the Options tab, in the Timeline group, choose the Report
Connections toolbar command. The Report Connections dialog box appears. At this point, we have created a
dashboard. The next step is to publish it to SharePoint Server , where it can be used by others. First, we make
some adjustments that affect how the workbook is displayed. Then, we specify Excel Services data
authentication settings for the external data connection that we use. Next, we specify publish options for the
workbook. Finally, we publish the workbook to SharePoint Server We begin by making adjustments to the
workbook. By default, our example dashboard displays gridlines on the worksheet that contains our
dashboard. In addition, by default, the worksheet is called Sheet1. We can make some minor adjustments that
will improve how the dashboard will be displayed. To make minor display improvements to the workbook In
Excel, choose the View tab. To remove gridlines from the view, on the View tab, in the Show group, clear the
Gridlines check box. To remove row and column headings, on the View tab, in the Show group, clear the
Headings check box. To rename the worksheet, right-click its tab where it says Sheet1, and then choose
Rename. Immediately type a new name for the worksheet, such as SalesDashboard, and then press the Enter
key. On the File tab, choose Save. The workbook we created uses an external data connection that we want to
keep active when we publish the workbook. To ensure that the data connection remains live so that data
refresh is supported in Excel Services, we must specify authentication settings. To specify authentication
settings for the external data connection In Excel, on the Data tab, choose the Connections toolbar command.
Choose the Properties button. In the Excel Services Authentication Settings dialog box, take one of the
following steps: If Excel Services is configured to use the unattended service account, select None, and then
choose the OK button. Important If you do not know which option to choose, contact a SharePoint
administrator. Choose the OK button to close the Connection Properties dialog box. If you see a message that
states that the connection in the workbook will no longer be identical to the connection that is defined in the
external file, choose Yes. Choose the Close button to close the Workbook Connections dialog box. When we
created the reports for the dashboard, we gave each one a unique name and defined it as a named item in
Excel. In addition to publishing the workbook to SharePoint Server , we should publish the named items that
we defined.

Page 2

DATA ANALYSIS USING SQL AND EXCEL pdf
2: Data Analysis Using SQL and Excel, 2nd Edition - pdf - Free IT eBooks Download
Learn to perform sophisticated data analysis using SQL and Excel. SQL is the essential language for querying
databases, and Excel is the most popular tool for data presentation and analysis.

SQL is simple and easy to understand. If you do so, you will need a data server to practice. So I recommend
through this article first: And why is it good? As you can see, SQL and Excel are quite similar. Both of them
present data in a 2-dimensional table format with rows and columns. Both are very structured, very
transparent. However there are differences as well. There are 2 major things that you should know as a
beginner in SQL: The first one is the performance. The second is how you access your data. Excel is primarily
a Graphical User Interface aka. You can scroll, type your formula, select your range with your cursor, etc. See
the gifs below: When you use SQL for data analysis, you will use it most probably for simple tasks: What
about Python, R and bash? If you have done my previous bash or Python tutorials, you might ask: The answer
isâ€¦ well, there is no categorical answer for this question! First, please go through this article. The good news
is that all SQL languages are very similar â€” if you learn postgreSQL, it will be a matter of hours or even
minutes to adapt to another one. A data server with Terminal or iTerm access. PostgreSQL installed on your
data server. Pgadmin4 or SQL Workbench on your computer. If something is missing, please read the article
again: You will write your first SQL query in a minute! First access your SQL database from the command
line. You have done this once; we will just repeat the same process: As I have already given access to my user,
I just have to type this command. Your prompt should change to this: You have full access to your SQL
database! As a test, type this: You have only one so farâ€¦ But this will change soon! If something is missing
or not working, please re-read this article: STEP 2 â€” Get some data! In this tutorial, we will use a really
small data set, called zoo. We have our new data table: If you want to quit from this view, please hit Q on your
keyboard. You can replace this with any other table name, if you have more tables. Every query should be
closed by a semicolon. You will use this syntax a lot from now on. Exactly what you have expected: You just
have to specify the name of the columns separated with commas. You can do something like this too: Take
this video course to practice everything that you learn here. Remember how was it done in bash? It was the
head command. And elephant is the value itself. In SQL you have to add the column where you are looking
for your value. Test yourself 1 This is an introductory article, so this first assignment will be a pretty easy one
as well: Select the first 3 zebras from the zoo table! The solution will be more or less the summary of this
article!
3: Data Analysis Using SQL and Excel, 2nd Edition â€“ ScanLibs
Data Analysis Using SQL and Excel Book Description: A practical guide to data mining using SQL and Excel. Data
Analysis Using SQL and Excel, 2nd Edition shows you how to leverage the two most popular tools for data query and
analysisâ€”SQL and Excelâ€”to perform sophisticated data analysis without the need for complex and expensive data
mining tools.

4: Data Miners Bookstore
Stay ahead with the world's most comprehensive technology and business learning platform. With Safari, you learn the
way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

5: Data Analysis Using SQL and Excel by Gordon S. Linoff
A practical guide to data mining using SQL and Excel. Data Analysis Using SQL and Excel, 2nd Edition shows you how
to leverage the two most popular tools for data query and analysisâ€”SQL and Excelâ€”to perform sophisticated data
analysis without the need for complex and expensive data mining tools.
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6: Data Analysis Using SQL and Excel, 2nd Edition - PDF eBook Free Download
Useful business analysis requires you to effectively transform data into actionable information. This book helps you use
SQL and Excel to extract business information from relational databases and use that data to define business
dimensions, store transactions about customers, produce results, and.

7: Data Analysis Using SQL and Excel : Books
Book Description: A practical guide to data mining using SQL and Excel. Data Analysis Using SQL and Excel, 2nd
Edition shows you how to leverage the two most popular tools for data query and analysisâ€”SQL and Excelâ€”to
perform sophisticated data analysis without the need for complex and expensive data mining tools.

8: SQL for Data Analysis - Tutorial for Beginners - ep1 - Data36
This page is a companion page for the book Data Analysis Using SQL and Excel. It provides the data sets and scripts
for loading the data sets, and Excel files associated with the book.

9: Data Analysis Using SQL and Excel - Gordon S. Linoff - Google Books
Book Description Useful business analysis requires you to effectively transform data into actionable information. This
book helps you use SQL and Excel to extract business information from relational databases and use that data to define
business dimensions, store transactions about customers, produce results, and more.
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